kagi - General search slow down. – Incident details

General search slow down.

Resolved
Degraded performance
Started 19 days agoLasted about 1 hour

Affected

Kagi Search

Major outage from 6:37 PM to 7:32 PM, Degraded performance from 7:32 PM to 7:50 PM

[Search] us-east4

Major outage from 6:37 PM to 7:32 PM, Degraded performance from 7:32 PM to 7:50 PM

[Search] us-west2

Major outage from 6:37 PM to 7:32 PM, Degraded performance from 7:32 PM to 7:50 PM

Updates
  • Resolved
    Resolved

    We are currently debugging the new problematic version, and will hold off deploying it until we have isolated and fixed the bug.

    Kagi search is running on the previous version that was deployed last week. So we are expecting no further issues.

  • Identified
    Identified

    We are rolling back to the previous version of search code that was deployed at Kaigi. The new version has some performance problems that caused increased latency for customers in us-west and us-east regions.

  • Investigating
    Investigating

    We have been tracking an increase in response times, which may lead to "Steam Timeout" errors. We are currently investigating the cause.